<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>Developers up in arms over Google Maps API ‘insane’ price hike</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://www.geoawesomeness.com/xmlrpc.php" />
    <link rel="icon" type="image/png" href="https://www.geoawesomeness.com/wp-content/uploads/2016/07/favicon.ico">
	<!-- This site is optimized with the Yoast SEO plugin v15.5 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="Read to find out how the outrageous hike in Google Maps API prices and other key changes will affect you and your projects | By Ishveena Singh" />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.geoawesomeness.com/developers-up-in-arms-over-google-maps-api-insane-price-hike/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Developers up in arms over Google Maps API ‘insane’ price hike" />
	<meta property="og:description" content="Read to find out how the outrageous hike in Google Maps API prices and other key changes will affect you and your projects | By Ishveena Singh" />
	<meta property="og:url" content="https://www.geoawesomeness.com/developers-up-in-arms-over-google-maps-api-insane-price-hike/" />
	<meta property="og:site_name" content="Geoawesomeness" />
	<meta property="article:published_time" content="2018-05-03T13:59:25+00:00" />
	<meta property="article:modified_time" content="2020-12-17T05:19:37+00:00" />
	<meta property="og:image" content="https://i1.wp.com/www.geoawesomeness.com/wp-content/uploads/2018/05/Google-Maps-API.png?fit=1583%2C752&#038;ssl=1" />
	<meta property="og:image:width" content="1583" />
	<meta property="og:image:height" content="752" />
	<meta name="twitter:card" content="summary" />
	<meta name="twitter:creator" content="@https://twitter.com/IshveenaSingh" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Ishveena Singh">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="3 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.geoawesomeness.com/#website","url":"https://www.geoawesomeness.com/","name":"Geoawesomeness","description":"The Location-Based Blog","potentialAction":[{"@type":"SearchAction","target":"https://www.geoawesomeness.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.geoawesomeness.com/developers-up-in-arms-over-google-maps-api-insane-price-hike/#primaryimage","inLanguage":"en-US","url":"https://i1.wp.com/www.geoawesomeness.com/wp-content/uploads/2018/05/Google-Maps-API.png?fit=1583%2C752&ssl=1","width":1583,"height":752},{"@type":"WebPage","@id":"https://www.geoawesomeness.com/developers-up-in-arms-over-google-maps-api-insane-price-hike/#webpage","url":"https://www.geoawesomeness.com/developers-up-in-arms-over-google-maps-api-insane-price-hike/","name":"Developers up in arms over Google Maps API \u2018insane\u2019 price hike","isPartOf":{"@id":"https://www.geoawesomeness.com/#website"},"primaryImageOfPage":{"@id":"https://www.geoawesomeness.com/developers-up-in-arms-over-google-maps-api-insane-price-hike/#primaryimage"},"datePublished":"2018-05-03T13:59:25+00:00","dateModified":"2020-12-17T05:19:37+00:00","author":{"@id":"https://www.geoawesomeness.com/#/schema/person/87e6209c3eb4ed49ebc099affc51f80b"},"description":"Read to find out how the outrageous hike in Google Maps API prices and other key changes will affect you and your projects | By Ishveena Singh","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.geoawesomeness.com/developers-up-in-arms-over-google-maps-api-insane-price-hike/"]}]},{"@type":"Person","@id":"https://www.geoawesomeness.com/#/schema/person/87e6209c3eb4ed49ebc099affc51f80b","name":"Ishveena Singh","image":{"@type":"ImageObject","@id":"https://www.geoawesomeness.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/e6d78d6d1ab72ff871bda9bf9813f104?s=96&d=identicon&r=g","caption":"Ishveena Singh"},"description":"Ishveena is a geospatial enthusiast and a veteran of creating and managing compelling digital content for organizations and individuals. When she is not making magic at her desk, you are likely to find her exploring nature, eating her way through life, or binge-watching funny animal videos.","sameAs":["https://www.linkedin.com/in/ishveena/","https://twitter.com/https://twitter.com/IshveenaSingh"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//apis.google.com' />
<link rel='dns-prefetch' href='//platform.twitter.com' />
<link rel='dns-prefetch' href='//platform.linkedin.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="Geoawesomeness &raquo; Feed" href="https://www.geoawesomeness.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Geoawesomeness &raquo; Comments Feed" href="https://www.geoawesomeness.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Geoawesomeness &raquo; Insane, shocking, outrageous: Developers react to changes in Google Maps API Comments Feed" href="https://www.geoawesomeness.com/developers-up-in-arms-over-google-maps-api-insane-price-hike/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.14.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
    (window.gaDevIds=window.gaDevIds||[]).push("dZGIzZG");
	var mi_version         = '7.14.0';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-30205660-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	if ( 'undefined' === typeof gaOptout ) {
		function gaOptout() {
			__gaTrackerOptout();
		}
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-30205660-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.geoawesomeness.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='validate-engine-css-css'  href='https://www.geoawesomeness.com/wp-content/plugins/wysija-newsletters/css/validationEngine.jquery.css?ver=2.14' type='text/css' media='all' />
<link rel='stylesheet' id='mscw-main-style-css'  href='https://www.geoawesomeness.com/wp-content/plugins/mailchimp-subscriber-chiclet/css/main.css?ver=5.6' type='text/css' media='all' />
<link rel='stylesheet' id='mailchimpSF_main_css-css'  href='https://www.geoawesomeness.com/?mcsf_action=main_css&#038;ver=5.6' type='text/css' media='all' />
<!--[if IE]>
<link rel='stylesheet' id='mailchimpSF_ie_css-css'  href='https://www.geoawesomeness.com/wp-content/plugins/mailchimp/css/ie.css?ver=5.6' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.6/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='lets-review-css'  href='https://www.geoawesomeness.com/wp-content/plugins/lets-review/frontend/css/lets-review-style.css?ver=1.2.0' type='text/css' media='all' />
<link rel='stylesheet' id='ce_responsive-css'  href='https://www.geoawesomeness.com/wp-content/plugins/simple-embed-code/css/video-container.min.css?ver=5.6' type='text/css' media='all' />
<link rel='stylesheet' id='mc4wp-form-basic-css'  href='https://www.geoawesomeness.com/wp-content/plugins/mailchimp-for-wp/assets/css/form-basic.min.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='monsterinsights-popular-posts-style-css'  href='https://www.geoawesomeness.com/wp-content/plugins/google-analytics-for-wordpress/assets/css/frontend.min.css?ver=7.14.0' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css'  href='https://www.geoawesomeness.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=c784b8db3e66cd68082f3ff7aa2d70e6' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C600%2C700%7CRoboto%3A400%2C500%2C700&#038;display=swap&#038;ver=10.3.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='evcal_google_fonts-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400%2C300%7COpen+Sans%3A700%2C400%2C400i%7CRoboto%3A700%2C400&#038;ver=5.6' type='text/css' media='screen' />
<link rel='stylesheet' id='evcal_cal_default-css'  href='//www.geoawesomeness.com/wp-content/plugins/eventON/assets/css/eventon_styles.css?ver=3.0.6' type='text/css' media='all' />
<link rel='stylesheet' id='evo_font_icons-css'  href='//www.geoawesomeness.com/wp-content/plugins/eventON/assets/fonts/all.css?ver=3.0.6' type='text/css' media='all' />
<link rel='stylesheet' id='eventon_dynamic_styles-css'  href='//www.geoawesomeness.com/wp-content/plugins/eventON/assets/css/eventon_dynamic_styles.css?ver=3.0.6' type='text/css' media='all' />
<link rel='stylesheet' id='meks-ads-widget-css'  href='https://www.geoawesomeness.com/wp-content/plugins/meks-easy-ads-widget/css/style.css?ver=2.0.4' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://www.geoawesomeness.com/wp-content/themes/Newspaper/style.css?ver=10.3.9.1' type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>
<link rel='stylesheet' id='ulp-css'  href='https://www.geoawesomeness.com/wp-content/plugins/layered-popups/css/style.min.css?ver=5.91' type='text/css' media='all' />
<link rel='stylesheet' id='ulp-link-buttons-css'  href='https://www.geoawesomeness.com/wp-content/plugins/layered-popups/css/link-buttons.min.css?ver=5.91' type='text/css' media='all' />
<link rel='stylesheet' id='animate.css-css'  href='https://www.geoawesomeness.com/wp-content/plugins/layered-popups/css/animate.min.css?ver=5.91' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='https://www.geoawesomeness.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=4.11.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-legacy-framework-front-style-css'  href='https://www.geoawesomeness.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/css/td_legacy_main.css?ver=c784b8db3e66cd68082f3ff7aa2d70e6' type='text/css' media='all' />
<link rel='stylesheet' id='td-standard-pack-framework-front-style-css'  href='https://www.geoawesomeness.com/wp-content/plugins/td-standard-pack/Newspaper/assets/css/td_standard_pack_main.css?ver=6b62588d33477b8e3dc5b8b3c9c8d86c' type='text/css' media='all' />
<link rel='stylesheet' id='tdb_front_style-css'  href='https://www.geoawesomeness.com/wp-content/plugins/td-cloud-library/assets/css/tdb_less_front.css?ver=a50385a2d79d6600973a7e697f735a0b' type='text/css' media='all, print' />
<link rel='stylesheet' id='sedlex_styles-css'  href='https://www.geoawesomeness.com/wp-content/sedlex/inline_styles/e89de060a8e0c1766552c342571e861e39caa6e5.css?ver=20201230' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/9.2.1/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/5.6/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.6/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.2.1/_inc/build/related-posts/related-posts.min.js' id='jetpack_related-posts-js'></script>
<script type='text/javascript' id='monsterinsights-frontend-script-js-extra'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/www.geoawesomeness.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.geoawesomeness.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.14.0' id='monsterinsights-frontend-script-js'></script>
<script type='text/javascript' src='https://www.geoawesomeness.com/wp-content/sedlex/inline_scripts/2ada9916e604adfcfb575a8f514fd148ebf436ec.js?ver=20201230' id='sedlex_scripts-js'></script>
<link rel="https://api.w.org/" href="https://www.geoawesomeness.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.geoawesomeness.com/wp-json/wp/v2/posts/21437" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.geoawesomeness.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.geoawesomeness.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.6" />
<link rel='shortlink' href='https://wp.me/p2udiP-5zL' />
<link rel="alternate" type="application/json+oembed" href="https://www.geoawesomeness.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.geoawesomeness.com%2Fdevelopers-up-in-arms-over-google-maps-api-insane-price-hike%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.geoawesomeness.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.geoawesomeness.com%2Fdevelopers-up-in-arms-over-google-maps-api-insane-price-hike%2F&#038;format=xml" />

<!--BEGIN: TRACKING CODE MANAGER BY INTELLYWP.COM IN HEAD//-->
<!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '1120119804739443'); // Insert your pixel ID here.
fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1120119804739443&ev=PageView&noscript=1"
/></noscript>
<!-- DO NOT MODIFY -->
<!-- End Facebook Pixel Code -->
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/21794102469/HomePageTop300x250', [300, 250], 'div-gpt-ad-1549131014684-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-5968728424329894",
          enable_page_level_ads: true
     });
</script>
<!--END: https://wordpress.org/plugins/tracking-code-manager IN HEAD//--><!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
        <script>
        window.tdb_globals = {"wpRestNonce":"e08bb4dcdf","wpRestUrl":"https:\/\/www.geoawesomeness.com\/wp-json\/","permalinkStructure":"\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};
    </script>
    			<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/www.geoawesomeness.com\/wp-admin\/","wpRestNonce":"e08bb4dcdf","wpRestUrl":"https:\/\/www.geoawesomeness.com\/wp-json\/","permalinkStructure":"\/%postname%\/"};
			</script>
			

<!-- EventON Version -->
<meta name="generator" content="EventON 3.0.6" />

<meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://www.geoawesomeness.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="https://www.geoawesomeness.com/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]-->			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<style>.fb_iframe_widget_lift {width: 100% !important; height: 100% !important;}</style>
<!-- JS generated by theme -->

<script>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</script>

<style></style>
		<script>
			var ulp_cookie_value = "ilovelencha";
			var ulp_recaptcha_enable = "off";
			var ulp_onload_mode = "once-period";
			var ulp_onload_period = "3";
			var ulp_onload_popup = "1QK9YcqKLQO4U2h7*";
			var ulp_onload_delay = "5";
			var ulp_onload_close_delay = "0";
			var ulp_onexit_mode = "none";
			var ulp_onexit_period = "30";
			var ulp_onexit_popup = "lrFbD1oECBDsDnEg*";
			var ulp_onscroll_mode = "none";
			var ulp_onscroll_period = "30";
			var ulp_onscroll_popup = "lrFbD1oECBDsDnEg*";
			var ulp_onscroll_offset = "400";
			var ulp_onidle_mode = "none";
			var ulp_onidle_period = "5";
			var ulp_onidle_popup = "";
			var ulp_onidle_delay = "30";
			var ulp_onabd_mode = "none";
			var ulp_onabd_period = "5";
			var ulp_onabd_popup = "";
		</script>


<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://www.geoawesomeness.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.geoawesomeness.com/topics/geo-news/",
                    "name": "Geo NEWS"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.geoawesomeness.com/developers-up-in-arms-over-google-maps-api-insane-price-hike/",
                    "name": "Insane, shocking, outrageous: Developers react to changes in Google Maps API"                                
                }
            }    
        ]
    }
</script>
			<link rel="stylesheet" type="text/css" id="wp-custom-css" href="https://www.geoawesomeness.com/?custom-css=3977b9da10" />
		
<!-- Button style compiled by theme -->

<style>
    .tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                .tdm-social-item i {
                    color: #bc2931;
                }
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                    background-color: #bc2931;
                }
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #bc2931;
                }
                .tdm-btn-style1 {
					background-color: #bc2931;
				}
				.tdm-btn-style2:before {
				    border-color: #bc2931;
				}
				.tdm-btn-style2 {
				    color: #bc2931;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #bc2931;
                    -moz-box-shadow: 0 2px 16px #bc2931;
                    box-shadow: 0 2px 16px #bc2931;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #bc2931;
                    -moz-box-shadow: 0 4px 26px #bc2931;
                    box-shadow: 0 4px 26px #bc2931;
				}
</style>

<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>	<style id="tdw-css-placeholder"></style></head>

<body class="post-template-default single single-post postid-21437 single-format-standard td-standard-pack developers-up-in-arms-over-google-maps-api-insane-price-hike global-block-template-1 newspaper wpb-js-composer js-comp-ver-4.11.2 vc_responsive td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>

    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/GeoAwesomeness" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://instagram.com/geoawesomeness" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.linkedin.com/company/geoawesomeness" title="Linkedin">
                <i class="td-icon-font td-icon-linkedin"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://feeds.feedburner.com/Geoawesomeness" title="RSS">
                <i class="td-icon-font td-icon-rss"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/geoawesomeness" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://vimeo.com/geoawesomeness" title="Vimeo">
                <i class="td-icon-font td-icon-vimeo"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/channel/UCqGv3p_twfy-LT86l52Wzdg" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="mailto:info@geoawesomeness.com" title="Mail">
                <i class="td-icon-font td-icon-mail-1"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-categories-new-container"><ul id="menu-categories-new" class="td-mobile-main-menu"><li id="menu-item-24337" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-has-children menu-item-first menu-item-24337"><a href="https://www.geoawesomeness.com/tag/startups/">Startups<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-24338" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24338"><a href="https://www.geoawesomeness.com/topics/the-next-geo/">The Next Geo</a></li>
</ul>
</li>
<li id="menu-item-24339" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-24339"><a href="https://www.geoawesomeness.com/topics/geotrends/">GeoTrends<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-24356" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-24356"><a href="https://www.geoawesomeness.com/tag/geotrends-2019/">GeoTrends 2019</a></li>
	<li id="menu-item-24357" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-24357"><a href="https://www.geoawesomeness.com/tag/geotrends-2018/">GeoTrends 2018</a></li>
	<li id="menu-item-24358" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-24358"><a href="https://www.geoawesomeness.com/tag/geotrends-2017/">GeoTrends 2017</a></li>
</ul>
</li>
<li id="menu-item-24340" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-24340"><a href="https://www.geoawesomeness.com/topics/geo-business/">Geo Business<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-24341" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-24341"><a href="https://www.geoawesomeness.com/tag/top-100-geospatial-companies/">Top 100 Geospatial Companies</a></li>
	<li id="menu-item-24346" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-24346"><a href="https://www.geoawesomeness.com/tag/drones/">Drones</a></li>
	<li id="menu-item-24336" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24336"><a href="https://www.geoawesomeness.com/topics/apps/">Apps</a></li>
</ul>
</li>
<li id="menu-item-24342" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-24342"><a href="https://www.geoawesomeness.com/topics/geo-business/jobs-in-geo/">Jobs<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-24545" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24545"><a href="https://www.geoawesomeness.com/geospatial-jobs-newsletter/">Sign up to the &#8220;Jobs in Geo&#8221; newsletter</a></li>
	<li id="menu-item-27275" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27275"><a href="https://www.geoawesomeness.com/jobs/">Jobs Dashboard</a></li>
	<li id="menu-item-24391" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24391"><a href="https://www.geoawesomeness.com/submit-a-job/">Submit a job</a></li>
</ul>
</li>
<li id="menu-item-24343" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-24343"><a href="https://www.geoawesomeness.com/topics/programming/">Programming</a></li>
<li id="menu-item-24344" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-24344"><a href="https://www.geoawesomeness.com/knowledge-base/">Knowledge Base<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-24345" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-24345"><a href="https://www.geoawesomeness.com/tag/geoawesomequiz/">GeoawesomeQuiz</a></li>
	<li id="menu-item-24347" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-24347"><a href="https://www.geoawesomeness.com/tag/geo-research/">Geo Research</a></li>
	<li id="menu-item-24350" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24350"><a href="https://www.geoawesomeness.com/knowledge-base/location-based-services/">Location-Based Services</a></li>
	<li id="menu-item-24352" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24352"><a href="https://www.geoawesomeness.com/knowledge-base/geospatial-revolution-videos/">Geospatial Revolution Videos</a></li>
	<li id="menu-item-24351" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24351"><a href="https://www.geoawesomeness.com/knowledge-base/location-based-marketing/">Location-Based Marketing</a></li>
</ul>
</li>
<li id="menu-item-24359" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-24359"><a href="https://www.geoawesomeness.com/topics/geo-news/">Geo NEWS</a></li>
<li id="menu-item-24361" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-24361"><a href="https://www.geoawesomeness.com/event-directory/">Events<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-24362" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24362"><a href="https://www.geoawesomeness.com/topics/events/">Events</a></li>
	<li id="menu-item-24364" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24364"><a href="https://www.geoawesomeness.com/media-partnership/">Media Partnership</a></li>
	<li id="menu-item-24392" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24392"><a href="https://www.geoawesomeness.com/submit-new-event/">Submit New Event</a></li>
</ul>
</li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
            <div id="login-form-mobile" class="td-register-section">
            
            <div id="td-login-mob" class="td-login-animation td-login-hide-mob">
            	<!-- close button -->
	            <div class="td-login-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Sign in</div>
	                <!-- close button -->
		            <div class="td-mobile-close">
		                <a href="#"><i class="td-icon-close-mobile"></i></a>
		            </div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
	                <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
	                <div class="td-login-info-text">
	                <a href="#" id="forgot-pass-link-mob">Forgot your password?</a>
	                </div>
	                <div class="td-login-register-link">
	                
	                </div>
	                
	                

                </div>
            </div>

            
            
            
            
            <div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">
                <!-- close button -->
	            <div class="td-forgot-pass-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Password recovery</div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title">Recover your password</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
	                <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
                </div>
            </div>
        </div>
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search">
		<form method="get" class="td-search-form" action="https://www.geoawesomeness.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob" class="td-ajax-search-flex"></div>
	</div>
</div>

    <div id="td-outer-wrap" class="td-theme-wrap">
    
        
            <div class="tdc-header-wrap ">

            <!--
Header style 9
-->

<div class="td-header-wrap td-header-style-9 ">
    
            <div class="td-header-top-menu-full td-container-wrap ">
            <div class="td-container td-header-row td-header-top-menu">
                
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	<div class="menu-top-container"><ul id="menu-top" class="top-header-menu"><li id="menu-item-213" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-213"><a href="https://www.geoawesomeness.com/about_geoawesomeness/">About us</a></li>
<li id="menu-item-24330" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-24330"><a href="https://www.geoawesomeness.com/master-plan/">Master Plan</a></li>
<li id="menu-item-116" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-116"><a href="https://www.geoawesomeness.com/contact-us/">Contact us</a></li>
<li id="menu-item-24383" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-24383"><a href="https://www.geoawesomeness.com/get-involved-with-geoawesomeness-join-the-team/">Get involved</a></li>
<li id="menu-item-6458" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-6458"><a href="https://www.geoawesomeness.com/submit-a-guest-post/">Submit</a>
<ul class="sub-menu">
	<li id="menu-item-210" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-210"><a href="https://www.geoawesomeness.com/submit-a-guest-post/">Submit Guest Post</a></li>
	<li id="menu-item-2038" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-2038"><a href="https://www.geoawesomeness.com/submit-new-event/">Submit New Event</a></li>
	<li id="menu-item-24394" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-24394"><a href="https://www.geoawesomeness.com/submit-a-job/">Submit a job</a></li>
</ul>
</li>
<li id="menu-item-123" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-123"><a href="https://www.geoawesomeness.com/advertise/">Advertise</a></li>
<li id="menu-item-212" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-212"><a href="https://www.geoawesomeness.com/terms-of-use/">Terms of Use</a></li>
</ul></div></div>
        <div class="td-header-sp-top-widget">
    
    
        
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/GeoAwesomeness" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://instagram.com/geoawesomeness" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.linkedin.com/company/geoawesomeness" title="Linkedin">
                <i class="td-icon-font td-icon-linkedin"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://feeds.feedburner.com/Geoawesomeness" title="RSS">
                <i class="td-icon-font td-icon-rss"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/geoawesomeness" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://vimeo.com/geoawesomeness" title="Vimeo">
                <i class="td-icon-font td-icon-vimeo"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/channel/UCqGv3p_twfy-LT86l52Wzdg" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="mailto:info@geoawesomeness.com" title="Mail">
                <i class="td-icon-font td-icon-mail-1"></i>
            </a>
        </span>    </div>    </div>

<!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <div class="td-login-wrap">
                        <a href="#" class="td-back-button"><i class="td-icon-modal-back"></i></a>
                        <div id="td-login-div" class="td-login-form-div td-display-block">
                            <div class="td-login-panel-title">Sign in</div>
                            <div class="td-login-panel-descr">Welcome! Log into your account</div>
                            <div class="td_display_err"></div>
                            <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email" value="" required><label>your username</label></div>
	                        <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" required><label>your password</label></div>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
                            
                            
                            
                            
                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
                            <div class="td-login-panel-title">Password recovery</div>
                            <div class="td-login-panel-descr">Recover your password</div>
                            <div class="td_display_err"></div>
                            <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label>your email</label></div>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
                            <div class="td-login-info-text">A password will be e-mailed to you.</div>
                        </div>
                        
                        
                    </div>
                </div>
                            </div>
        </div>
    
    <div class="td-banner-wrap-full td-logo-wrap-full  td-container-wrap ">
        <div class="td-header-sp-logo">
            			<a class="td-main-logo" href="https://www.geoawesomeness.com/">
				<img src="https://www.geoawesomeness.com/wp-content/uploads/2016/07/geoawesomeness-logo.png" alt=""/>
				<span class="td-visual-hidden">Geoawesomeness</span>
			</a>
		        </div>
    </div>

    <div class="td-header-menu-wrap-full td-container-wrap ">
        
        <div class="td-header-menu-wrap td-header-gradient ">
            <div class="td-container td-header-row td-header-main-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-header">
                <a class="td-main-logo" href="https://www.geoawesomeness.com/">
            <img src="https://www.geoawesomeness.com/wp-content/uploads/2016/07/geoawesomeness-logo.png" alt=""/>
        </a>
        </div>
    <div class="menu-categories-new-container"><ul id="menu-categories-new-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-has-children menu-item-first td-menu-item td-normal-menu menu-item-24337"><a href="https://www.geoawesomeness.com/tag/startups/">Startups</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-24338"><a href="https://www.geoawesomeness.com/topics/the-next-geo/">The Next Geo</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-24339"><a href="https://www.geoawesomeness.com/topics/geotrends/">GeoTrends</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag td-menu-item td-normal-menu menu-item-24356"><a href="https://www.geoawesomeness.com/tag/geotrends-2019/">GeoTrends 2019</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag td-menu-item td-normal-menu menu-item-24357"><a href="https://www.geoawesomeness.com/tag/geotrends-2018/">GeoTrends 2018</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag td-menu-item td-normal-menu menu-item-24358"><a href="https://www.geoawesomeness.com/tag/geotrends-2017/">GeoTrends 2017</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-24340"><a href="https://www.geoawesomeness.com/topics/geo-business/">Geo Business</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag td-menu-item td-normal-menu menu-item-24341"><a href="https://www.geoawesomeness.com/tag/top-100-geospatial-companies/">Top 100 Geospatial Companies</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag td-menu-item td-normal-menu menu-item-24346"><a href="https://www.geoawesomeness.com/tag/drones/">Drones</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-24336"><a href="https://www.geoawesomeness.com/topics/apps/">Apps</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-24342"><a href="https://www.geoawesomeness.com/topics/geo-business/jobs-in-geo/">Jobs</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-24545"><a href="https://www.geoawesomeness.com/geospatial-jobs-newsletter/">Sign up to the &#8220;Jobs in Geo&#8221; newsletter</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-27275"><a href="https://www.geoawesomeness.com/jobs/">Jobs Dashboard</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-24391"><a href="https://www.geoawesomeness.com/submit-a-job/">Submit a job</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-24343"><a href="https://www.geoawesomeness.com/topics/programming/">Programming</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-24344"><a href="https://www.geoawesomeness.com/knowledge-base/">Knowledge Base</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag td-menu-item td-normal-menu menu-item-24345"><a href="https://www.geoawesomeness.com/tag/geoawesomequiz/">GeoawesomeQuiz</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag td-menu-item td-normal-menu menu-item-24347"><a href="https://www.geoawesomeness.com/tag/geo-research/">Geo Research</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-24350"><a href="https://www.geoawesomeness.com/knowledge-base/location-based-services/">Location-Based Services</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-24352"><a href="https://www.geoawesomeness.com/knowledge-base/geospatial-revolution-videos/">Geospatial Revolution Videos</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-24351"><a href="https://www.geoawesomeness.com/knowledge-base/location-based-marketing/">Location-Based Marketing</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-24359"><a href="https://www.geoawesomeness.com/topics/geo-news/">Geo NEWS</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-24361"><a href="https://www.geoawesomeness.com/event-directory/">Events</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-24362"><a href="https://www.geoawesomeness.com/topics/events/">Events</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-24364"><a href="https://www.geoawesomeness.com/media-partnership/">Media Partnership</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-24392"><a href="https://www.geoawesomeness.com/submit-new-event/">Submit New Event</a></li>
</ul>
</li>
</ul></div></div>


    <div class="header-search-wrap">
        <div class="td-search-btns-wrap">
            <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            <a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
        </div>

        <div class="td-drop-down-search" aria-labelledby="td-header-search-button">
            <form method="get" class="td-search-form" action="https://www.geoawesomeness.com/">
                <div role="search" class="td-head-form-search-wrap">
                    <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
                </div>
            </form>
            <div id="td-aj-search"></div>
        </div>
    </div>
            </div>
        </div>
    </div>

    
</div>
            </div>

            
    <div class="td-main-content-wrap td-container-wrap">

        <div class="td-container td-post-template-default ">
            <div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://www.geoawesomeness.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Geo NEWS" class="entry-crumb" href="https://www.geoawesomeness.com/topics/geo-news/">Geo NEWS</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Insane, shocking, outrageous: Developers react to changes in Google Maps API</span></div></div>

            <div class="td-pb-row">
                                        <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <article id="post-21437" class="post-21437 post type-post status-publish format-standard has-post-thumbnail category-geo-news category-programming tag-google-maps-api" itemscope itemtype="https://schema.org/Article"47>
        <div class="td-post-header">

            <!-- category --><ul class="td-category"><li class="entry-category"><a  href="https://www.geoawesomeness.com/topics/geo-news/">Geo NEWS</a></li><li class="entry-category"><a  href="https://www.geoawesomeness.com/topics/programming/">Programming</a></li></ul>
            <header class="td-post-title">
                <h1 class="entry-title">Insane, shocking, outrageous: Developers react to changes in Google Maps API</h1>
                                    <p class="td-post-sub-title">Is it time to switch to an alternative?</p>
                

                <div class="td-module-meta-info">
                    <!-- author --><div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://www.geoawesomeness.com/author/ishveenasingh/">Ishveena Singh</a><div class="td-author-line"> - </div> </div>                    <!-- date --><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-05-03T15:59:25+02:00" >May 3, 2018</time></span>                    <!-- comments --><div class="td-post-comments"><a href="https://www.geoawesomeness.com/developers-up-in-arms-over-google-maps-api-insane-price-hike/#comments"><i class="td-icon-comments"></i>197</a></div>                    <!-- views -->                </div>

            </header>

        </div>

        
        <div class="td-post-content tagdiv-type">
            <!-- image -->
            <!-- content --><p><img data-attachment-id="21438" data-permalink="https://www.geoawesomeness.com/developers-up-in-arms-over-google-maps-api-insane-price-hike/google-maps-api/" data-orig-file="https://i1.wp.com/www.geoawesomeness.com/wp-content/uploads/2018/05/Google-Maps-API.png?fit=1583%2C752&amp;ssl=1" data-orig-size="1583,752" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Google Maps API" data-image-description data-medium-file="https://i1.wp.com/www.geoawesomeness.com/wp-content/uploads/2018/05/Google-Maps-API.png?fit=300%2C143&amp;ssl=1" data-large-file="https://i1.wp.com/www.geoawesomeness.com/wp-content/uploads/2018/05/Google-Maps-API.png?fit=696%2C330&amp;ssl=1" loading="lazy" class="alignnone size-full wp-image-21438 jetpack-lazy-image" src="https://i1.wp.com/www.geoawesomeness.com/wp-content/uploads/2018/05/Google-Maps-API.png?resize=696%2C331&#038;ssl=1" alt width="696" height="331" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/www.geoawesomeness.com/wp-content/uploads/2018/05/Google-Maps-API.png?w=1583&amp;ssl=1 1583w, https://i1.wp.com/www.geoawesomeness.com/wp-content/uploads/2018/05/Google-Maps-API.png?resize=300%2C143&amp;ssl=1 300w, https://i1.wp.com/www.geoawesomeness.com/wp-content/uploads/2018/05/Google-Maps-API.png?resize=768%2C365&amp;ssl=1 768w, https://i1.wp.com/www.geoawesomeness.com/wp-content/uploads/2018/05/Google-Maps-API.png?resize=1024%2C486&amp;ssl=1 1024w, https://i1.wp.com/www.geoawesomeness.com/wp-content/uploads/2018/05/Google-Maps-API.png?resize=600%2C285&amp;ssl=1 600w, https://i1.wp.com/www.geoawesomeness.com/wp-content/uploads/2018/05/Google-Maps-API.png?resize=696%2C331&amp;ssl=1 696w, https://i1.wp.com/www.geoawesomeness.com/wp-content/uploads/2018/05/Google-Maps-API.png?resize=1068%2C507&amp;ssl=1 1068w, https://i1.wp.com/www.geoawesomeness.com/wp-content/uploads/2018/05/Google-Maps-API.png?resize=884%2C420&amp;ssl=1 884w, https://i1.wp.com/www.geoawesomeness.com/wp-content/uploads/2018/05/Google-Maps-API.png?w=1392&amp;ssl=1 1392w" data-lazy-sizes="(max-width: 696px) 100vw, 696px" data-lazy-src="https://i1.wp.com/www.geoawesomeness.com/wp-content/uploads/2018/05/Google-Maps-API.png?resize=696%2C331&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="21438" data-permalink="https://www.geoawesomeness.com/developers-up-in-arms-over-google-maps-api-insane-price-hike/google-maps-api/" data-orig-file="https://i1.wp.com/www.geoawesomeness.com/wp-content/uploads/2018/05/Google-Maps-API.png?fit=1583%2C752&amp;ssl=1" data-orig-size="1583,752" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Google Maps API" data-image-description="" data-medium-file="https://i1.wp.com/www.geoawesomeness.com/wp-content/uploads/2018/05/Google-Maps-API.png?fit=300%2C143&amp;ssl=1" data-large-file="https://i1.wp.com/www.geoawesomeness.com/wp-content/uploads/2018/05/Google-Maps-API.png?fit=696%2C330&amp;ssl=1" loading="lazy" class="alignnone size-full wp-image-21438" src="https://i1.wp.com/www.geoawesomeness.com/wp-content/uploads/2018/05/Google-Maps-API.png?resize=696%2C331&#038;ssl=1" alt="" width="696" height="331" srcset="https://i1.wp.com/www.geoawesomeness.com/wp-content/uploads/2018/05/Google-Maps-API.png?w=1583&amp;ssl=1 1583w, https://i1.wp.com/www.geoawesomeness.com/wp-content/uploads/2018/05/Google-Maps-API.png?resize=300%2C143&amp;ssl=1 300w, https://i1.wp.com/www.geoawesomeness.com/wp-content/uploads/2018/05/Google-Maps-API.png?resize=768%2C365&amp;ssl=1 768w, https://i1.wp.com/www.geoawesomeness.com/wp-content/uploads/2018/05/Google-Maps-API.png?resize=1024%2C486&amp;ssl=1 1024w, https://i1.wp.com/www.geoawesomeness.com/wp-content/uploads/2018/05/Google-Maps-API.png?resize=600%2C285&amp;ssl=1 600w, https://i1.wp.com/www.geoawesomeness.com/wp-content/uploads/2018/05/Google-Maps-API.png?resize=696%2C331&amp;ssl=1 696w, https://i1.wp.com/www.geoawesomeness.com/wp-content/uploads/2018/05/Google-Maps-API.png?resize=1068%2C507&amp;ssl=1 1068w, https://i1.wp.com/www.geoawesomeness.com/wp-content/uploads/2018/05/Google-Maps-API.png?resize=884%2C420&amp;ssl=1 884w, https://i1.wp.com/www.geoawesomeness.com/wp-content/uploads/2018/05/Google-Maps-API.png?w=1392&amp;ssl=1 1392w" sizes="(max-width: 696px) 100vw, 696px" data-recalc-dims="1" /></noscript></p>
<p><strong>This just in:</strong> <a href="https://www.geoawesomeness.com/amazon-location-service-maps-api/" target="_blank" rel="noopener noreferrer">Amazon teams with Esri, HERE to offer location-based data, mapping services</a></p>
<p>The honeymoon is over, guys – or it will be, on June 11, 2018. Google is making sweeping changes to its Maps API products. And by sweeping, we mean shocking.</p>
<p>Here’s what is happening:</p>
<ul>
<li>The 18 individual APIs Google Maps currently offers are being consolidated into three broad segments – Maps, Routes, and Places. But, you wouldn’t need to make any changes in your existing code; it will work just fine.</li>
<li>The Standard (no access to customer support) and Premium plans are being merged into one pay-as-you-go pricing plan. And the new fee structure is not pretty. Google is raising its prices by more than 1,400%. Obviously, no direct comparison figures of old and new prices have been provided by Google, but that’s the average surge that is being reported by developers.</li>
<li>All projects will need valid API keys, as Google has insisted before as well. Beginning June 11, keyless access will no longer be supported. Keyless calls to the Maps JavaScript API and Street View API will return low-resolution maps watermarked with “for development purposes only.”</li>
<li>You can no longer use the APIs in the first place unless you create a billing account and hand-over your credit card information to Google. This is applicable to all users – even those who have a simple map embedded on their website’s contact page.</li>
<li>You will get the first $200 of monthly usage for free. And that should be enough to cover the majority of users who have a simple map embedded on their website as mentioned above. But, for those who use Dynamic Maps, $200 will take care of only 28,000 free page loads <em>per month</em>. Why the emphasis on per month? Because right now, users get 25,000 free page loads per day. Let that sink in.</li>
<li>As every dark cloud must have a silver lining, customer support is now going to be free for all.</li>
<li>Google is protecting Android app developers from these changes by not charging for Mobile Native Static Maps and Mobile Native Dynamic Maps.</li>
</ul>
<p>We have always known that the search engine giant had its eyes set on making Maps its <a href="https://www.geoawesomeness.com/sundar-pichai-tells-google-plans-make-money-off-maps/">next billion dollar business</a>, but when Sundar Pichai shared thoughts on how the company plans to get there, he neglected to mention it would be looking to capitalize on its near monopoly in the market. For a geospatial platform as ubiquitous as Google, these changes are pretty draconian in nature and have the potential of stripping off thousands of location-based small businesses of their key functionality.</p>
<p>Naturally, the reactions from developers on the Internet have not been positive. As this user on <a href="https://www.reddit.com/r/webdev/comments/8gkmeo/starting_google_maps_platform_arrives_with/dydeswg/?context=3" rel="nofollow">Reddit</a> says, &#8220;Hmm, yearly 10 000$ -&gt; 200 000$ increase in cost based on our current average usage &#8211; twenty times?! Thank you google, investing a fraction of that to migration to competition.&#8221; And Twitter exploded with disappointment after the news broke:</p>
<blockquote class="twitter-tweet">
<p dir="ltr" lang="en">Thank you <a href="https://twitter.com/googlemaps?ref_src=twsrc%5Etfw">@googlemaps</a> for providing your service for free to me. Now, you have announced a price increase of ~1400%, reduced free API calls from 750K to 25K/month and want me to open a billing account w/ my credit card data. As a long-term supporter of <a href="https://twitter.com/openstreetmap?ref_src=twsrc%5Etfw">@openstreetmap</a>, I&#8217;ll switch</p>
<p>— Rolf F. Katzenberger (@PragmTeams) <a href="https://twitter.com/PragmTeams/status/991978196542337024?ref_src=twsrc%5Etfw">May 3, 2018</a></p></blockquote>
<blockquote class="twitter-tweet">
<p dir="ltr" lang="en">A quick notification &#8211; due to some asinine changes by Google to their map API, we will be contacting some clients to sort out their embedded maps. They are desperate to harvest credit card details before GDPR comes in, even on users who fall firmly into their free use bracket &#8230;</p>
<p>— Jemmett Fox Media (@Jemmettfoxmedia) <a href="https://twitter.com/Jemmettfoxmedia/status/991979932015194112?ref_src=twsrc%5Etfw">May 3, 2018</a></p></blockquote>
<blockquote class="twitter-tweet">
<p dir="ltr" lang="en">probably time to take experience with the Google Maps API off my CV then.</p>
<p>— ram &#x1f1ef;&#x1f1f2; (@MacSual) <a href="https://twitter.com/MacSual/status/991905736455147520?ref_src=twsrc%5Etfw">May 3, 2018</a></p></blockquote>
<p>For Shyam Sunder, Senior Director at Finland-based automotive startup Link Motion, the mistake of many egos is to be blamed for the monopolistic rise of Google Maps. “Especially in the automotive use case and its developers, the OEMs should see a clear advantage and its significance,” he says. “It’s the customers who are demanding Google Maps and I hope the likes of TomTom, HERE, and Sygic can come up with adoptions like the way Google maps started. Even today I see many issues by such providers who are still finding it tough to get out of their shells.”</p>
<p>So, what do you think geogeeks? Time to switch to an open-source alternative?</p>

<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-content_bottom tdi_1_a5a td_block_template_1 ">

<style>
/* custom css */
.tdi_1_a5a.td-a-rec{
					text-align: center;
				}.tdi_1_a5a .td-element-style{
					z-index: -1;
				}.tdi_1_a5a.td-a-rec-img{
				    text-align: left;
				}.tdi_1_a5a.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_1_a5a.td-a-rec-img {
				        text-align: center;
				    }
                }
</style><script type="text/javascript">
var td_screen_width = window.innerWidth;

	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-6074512664048955" data-ad-slot="9647473255"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-6074512664048955" data-ad-slot="9647473255"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6074512664048955" data-ad-slot="9647473255"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 

        </div>

        <footer>
            <!-- post pagination -->            <!-- review -->
            <div class="td-post-source-tags">
                <!-- source via -->                <!-- tags --><ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://www.geoawesomeness.com/tag/google-maps-api/">Google Maps API</a></li></ul>            </div>

            <div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://www.geoawesomeness.com/developers-up-in-arms-over-google-maps-api-insane-price-hike/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:auto; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.geoawesomeness.com%2Fdevelopers-up-in-arms-over-google-maps-api-insane-price-hike%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Insane%2C+shocking%2C+outrageous%3A+Developers+react+to+changes+in+Google+Maps+API&url=https%3A%2F%2Fwww.geoawesomeness.com%2Fdevelopers-up-in-arms-over-google-maps-api-insane-price-hike%2F&via=geoawesomeness">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.geoawesomeness.com/developers-up-in-arms-over-google-maps-api-insane-price-hike/&amp;media=https://www.geoawesomeness.com/wp-content/uploads/2018/05/Google-Maps-API.png&description=Read to find out how the outrageous hike in Google Maps API prices and other key changes will affect you and your projects | By Ishveena Singh">
                                        <div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
                                        <div class="td-social-but-text">Pinterest</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="https://api.whatsapp.com/send?text=Insane%2C+shocking%2C+outrageous%3A+Developers+react+to+changes+in+Google+Maps+API %0A%0A https://www.geoawesomeness.com/developers-up-in-arms-over-google-maps-api-insane-price-hike/">
                                        <div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
                                        <div class="td-social-but-text">WhatsApp</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>            <!-- next prev -->            <!-- author box --><div class="author-box-wrap"><a href="https://www.geoawesomeness.com/author/ishveenasingh/"><img alt src="https://secure.gravatar.com/avatar/e6d78d6d1ab72ff871bda9bf9813f104?s=96&#038;d=identicon&#038;r=g" class="avatar avatar-96 photo jetpack-lazy-image" height="96" width="96" loading="lazy" data-lazy-srcset="https://secure.gravatar.com/avatar/e6d78d6d1ab72ff871bda9bf9813f104?s=192&#038;d=identicon&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/e6d78d6d1ab72ff871bda9bf9813f104?s=96&amp;is-pending-load=1#038;d=identicon&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/e6d78d6d1ab72ff871bda9bf9813f104?s=96&#038;d=identicon&#038;r=g' srcset='https://secure.gravatar.com/avatar/e6d78d6d1ab72ff871bda9bf9813f104?s=192&#038;d=identicon&#038;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' loading='lazy'/></noscript></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://www.geoawesomeness.com/author/ishveenasingh/">Ishveena Singh</a></span></div><div class="td-author-description">Ishveena is a geospatial enthusiast and a veteran of creating and managing compelling digital content for organizations and individuals. When she is not making magic at her desk, you are likely to find her exploring nature, eating her way through life, or binge-watching funny animal videos.</div><div class="td-author-social">
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.linkedin.com/in/ishveena/" title="Linkedin">
                <i class="td-icon-font td-icon-linkedin"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="mailto:ishveena@gmail.com" title="Mail">
                <i class="td-icon-font td-icon-mail-1"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/IshveenaSingh" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div><div class="clearfix"></div></div></div>            <!-- meta --><span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Ishveena Singh"></span><meta itemprop="datePublished" content="2018-05-03T15:59:25+02:00"><meta itemprop="dateModified" content="2020-12-17T06:19:37+01:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.geoawesomeness.com/developers-up-in-arms-over-google-maps-api-insane-price-hike/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.geoawesomeness.com/wp-content/uploads/2016/07/geoawesomeness-logo.png"></span><meta itemprop="name" content="Geoawesomeness"></span><meta itemprop="headline " content="Insane, shocking, outrageous: Developers react to changes in Google Maps API"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://i1.wp.com/www.geoawesomeness.com/wp-content/uploads/2018/05/Google-Maps-API.png?fit=1583%2C752&ssl=1"><meta itemprop="width" content="1583"><meta itemprop="height" content="752"></span>        </footer>

    </article> <!-- /.post -->

    <div class="td_block_wrap td_block_related_posts tdi_2_f85 td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="tdi_2_f85" ><script>var block_tdi_2_f85 = new tdBlock();
block_tdi_2_f85.id = "tdi_2_f85";
block_tdi_2_f85.atts = '{"limit":6,"ajax_pagination":"next_prev","live_filter":"cur_post_same_tags","td_ajax_filter_type":"td_custom_related","class":"tdi_2_f85","td_column_number":3,"block_type":"td_block_related_posts","live_filter_cur_post_id":21437,"live_filter_cur_post_author":"67","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_2_f85","tdc_css_class_style":"tdi_2_f85_rand_style"}';
block_tdi_2_f85.td_column_number = "3";
block_tdi_2_f85.block_type = "td_block_related_posts";
block_tdi_2_f85.post_count = "6";
block_tdi_2_f85.found_posts = "9";
block_tdi_2_f85.header_color = "";
block_tdi_2_f85.ajax_pagination_infinite_stop = "";
block_tdi_2_f85.max_num_pages = "2";
tdBlocksArray.push(block_tdi_2_f85);
</script><h4 class="td-related-title td-block-title"><a id="tdi_3_f8e" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_2_f85" href="#">RELATED ARTICLES</a><a id="tdi_4_e77" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_2_f85" href="#">MORE FROM AUTHOR</a></h4><div id=tdi_2_f85 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.geoawesomeness.com/amazon-location-service-maps-api/" rel="bookmark" class="td-image-wrap " title="Amazon teams with Esri, HERE to offer location-based data, mapping services" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="amazon location service maps api story by Ishveena Singh" title="Amazon teams with Esri, HERE to offer location-based data, mapping services" data-type="image_tag" data-img-url="https://i2.wp.com/www.geoawesomeness.com/wp-content/uploads/2020/12/amazon-location-map-api-story-by-Ishveena-Singh-1.png?resize=218%2C150&ssl=1"  width="218" height="150" /></a></div>                <a href="https://www.geoawesomeness.com/topics/apps/location-based-services/" class="td-post-category">Location-Based Services</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.geoawesomeness.com/amazon-location-service-maps-api/" rel="bookmark" title="Amazon teams with Esri, HERE to offer location-based data, mapping services">Amazon teams with Esri, HERE to offer location-based data, mapping services</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.geoawesomeness.com/google-maps-platform-local-context-cloud-customization-api/" rel="bookmark" class="td-image-wrap " title="Google Maps Platform intros local context, Cloud-based Maps styling" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="google maps api local context story by Ishveena Singh" title="Google Maps Platform intros local context, Cloud-based Maps styling" data-type="image_tag" data-img-url="https://i1.wp.com/www.geoawesomeness.com/wp-content/uploads/2020/06/google-maps-local-context.png?resize=218%2C150&ssl=1"  width="218" height="150" /></a></div>                <a href="https://www.geoawesomeness.com/topics/programming/" class="td-post-category">Programming</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.geoawesomeness.com/google-maps-platform-local-context-cloud-customization-api/" rel="bookmark" title="Google Maps Platform intros local context, Cloud-based Maps styling">Google Maps Platform intros local context, Cloud-based Maps styling</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.geoawesomeness.com/google-plus-codes-places-autocomplete/" rel="bookmark" class="td-image-wrap " title="Google’s open-source digital addressing system Plus Codes now in Places Autocomplete" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="Google Plus Codes" title="Google’s open-source digital addressing system Plus Codes now in Places Autocomplete" data-type="image_tag" data-img-url="https://i1.wp.com/www.geoawesomeness.com/wp-content/uploads/2020/05/google-plus-codes-1.png?resize=218%2C150&ssl=1"  width="218" height="150" /></a></div>                <a href="https://www.geoawesomeness.com/topics/apps/location-based-services/" class="td-post-category">Location-Based Services</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.geoawesomeness.com/google-plus-codes-places-autocomplete/" rel="bookmark" title="Google’s open-source digital addressing system Plus Codes now in Places Autocomplete">Google’s open-source digital addressing system Plus Codes now in Places Autocomplete</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid-->

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.geoawesomeness.com/all-need-know-tomtom-maps-api/" rel="bookmark" class="td-image-wrap " title="All you need to know about TomTom’s Mapping APIs" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="All you need to know about TomTom’s Mapping APIs" data-type="image_tag" data-img-url="https://i2.wp.com/www.geoawesomeness.com/wp-content/uploads/2012/09/TomTom-Taxi.jpg?resize=218%2C150&ssl=1"  width="218" height="150" /></a></div>                <a href="https://www.geoawesomeness.com/topics/geo-business/" class="td-post-category">Geo Business</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.geoawesomeness.com/all-need-know-tomtom-maps-api/" rel="bookmark" title="All you need to know about TomTom’s Mapping APIs">All you need to know about TomTom’s Mapping APIs</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.geoawesomeness.com/google-maps-api-alternatives-best-cheap-affordable/" rel="bookmark" class="td-image-wrap " title="Google Maps API pricing got you down? See these awesome alternatives" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Google Maps API pricing got you down? See these awesome alternatives" data-type="image_tag" data-img-url="https://i0.wp.com/www.geoawesomeness.com/wp-content/uploads/2018/05/API.jpg?resize=218%2C150&ssl=1"  width="218" height="150" /></a></div>                <a href="https://www.geoawesomeness.com/topics/programming/" class="td-post-category">Programming</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.geoawesomeness.com/google-maps-api-alternatives-best-cheap-affordable/" rel="bookmark" title="Google Maps API pricing got you down? See these awesome alternatives">Google Maps API pricing got you down? See these awesome alternatives</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.geoawesomeness.com/google-maps-will-now-power-location-aware-augmented-reality-games/" rel="bookmark" class="td-image-wrap " title="Your next favorite AR game will be built on Google Maps" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="Google Maps Games API" title="Your next favorite AR game will be built on Google Maps" data-type="image_tag" data-img-url="https://i1.wp.com/www.geoawesomeness.com/wp-content/uploads/2018/03/google-maps-game-API.png?resize=218%2C150&ssl=1"  width="218" height="150" /></a></div>                <a href="https://www.geoawesomeness.com/topics/apps/location-based-games/" class="td-post-category">Location-Based Games</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.geoawesomeness.com/google-maps-will-now-power-location-aware-augmented-reality-games/" rel="bookmark" title="Your next favorite AR game will be built on Google Maps">Your next favorite AR game will be built on Google Maps</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_2_f85" data-td_block_id="tdi_2_f85"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-tdi_2_f85" data-td_block_id="tdi_2_f85"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->
    
<div id="disqus_thread"></div>
                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <div class="td_block_wrap td_block_social_counter td_block_widget tdi_5_e5f td-pb-border-top td_block_template_1">
<style>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</style>
<style>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</style><div class="td-block-title-wrap"><h4 class="block-title td-block-title"><span class="td-pulldown-size">STAY CONNECTED</span></h4></div><div class="td-social-list"><div class="td_social_type td-pb-margin-side td_social_facebook"><div class="td-social-box"><div class="td-sp td-sp-facebook"></div><span class="td_social_info td_social_info_counter">24,354</span><span class="td_social_info td_social_info_name">Fans</span><span class="td_social_button"><a href="https://www.facebook.com/302602119827463"  target="_blank" >Like</a></span></div></div><div class="td_social_type td-pb-margin-side td_social_instagram"><div class="td-social-box"><div class="td-sp td-sp-instagram"></div><span class="td_social_info td_social_info_counter">21,119</span><span class="td_social_info td_social_info_name">Followers</span><span class="td_social_button"><a href="https://instagram.com/geoawesomeness#"  target="_blank" >Follow</a></span></div></div><div class="td_social_type td-pb-margin-side td_social_twitter"><div class="td-social-box"><div class="td-sp td-sp-twitter"></div><span class="td_social_info td_social_info_counter">25,079</span><span class="td_social_info td_social_info_name">Followers</span><span class="td_social_button"><a href="https://twitter.com/geoawesomeness"  target="_blank" >Follow</a></span></div></div></div></div> <!-- ./block --><aside class="td_block_template_1 widget EvcalWidget"><h4 class="block-title"><span>GEOAWESOMENESS DIGITAL MEETUPS</span></h4><div id='evcal_widget' class='evo_widget'><!-- EventON Calendar --><div id='evcal_calendar_357' class='ajde_evcal_calendar  box_2 ajax_loading_cal' ><div id='evcal_head' class='calendar_header ' ><div class='evo_cal_above'><span class='evo-gototoday-btn' style='display:none' data-mo='12' data-yr='2020' data-dy=''>Current Month</span></div><div class='evo_cal_above_content'></div><div class='clear'></div></div><div id='eventon_loadbar_section'><div id='eventon_loadbar'></div></div><div class='evo_ajax_load_events'><span></span><span></span><span></span></div><!-- Events List --><div id='evcal_list' class='eventon_events_list '>			<div class='clear'></div>
			</div>
			<div class='clear'></div>
					 	<div id='evcal_footer' class='evo_bottom' style='display:none'>
		 		<div class='evo_cal_data'  data-sc='{"accord":"no","bottom_nav":"no","cal_id":"","cal_init_nonajax":"no","calendar_type":"default","etc_override":"no","evc_open":"no","event_count":"0","event_location":"all","event_order":"ASC","event_organizer":"all","event_past_future":"future","event_tag":"all","event_type":"all","event_type_2":"all","event_type_3":"all","event_type_4":"all","event_type_5":"all","eventtop_style":0,"exp_jumper":"no","exp_so":"no","filter_relationship":"AND","filter_show_set_only":"no","filter_type":"default","filters":"yes","fixed_month":"12","fixed_year":"2020","focus_end_date_range":"1619827199","focus_start_date_range":"1606780800","ft_event_priority":"no","hide_arrows":"no","hide_empty_months":"yes","hide_end_time":"no","hide_ft":"no","hide_month_headers":"no","hide_mult_occur":"no","hide_past":"yes","hide_past_by":"ee","hide_so":"no","ics":"no","jumper":"no","jumper_count":5,"jumper_offset":"0","lang":"L1","layout_changer":"no","livenow_bar":"yes","mapformat":"roadmap","mapiconurl":"","maps_load":"yes","mapscroll":"true","mapzoom":"12","members_only":"no","ml_priority":"no","month_incre":0,"number_of_months":"5","only_ft":"no","pec":"","s":"","search":"","search_all":"no","sep_month":"no","show_et_ft_img":"no","show_limit":"no","show_limit_ajax":"no","show_limit_paged":1,"show_limit_redir":"","show_repeats":"no","show_upcoming":"yes","show_year":"no","sort_by":"sort_date","tile_bg":0,"tile_bg_size":"full","tile_count":2,"tile_height":0,"tile_style":0,"tiles":"no","ux_val":"0","view_switcher":"no","wpml_l1":"","wpml_l2":"","wpml_l3":"","yl_priority":"no","fixed_day":"1","_cver":"3.0.6"}' data-od='{"lang_no_events":"No Events"}'></div>
		 		<div class='evo_cal_events' data-events=""></div>
		 	</div>
				
			
						</div><!-- EventON End -->
			</div></aside><aside class="td_block_template_1 widget widget_media_image"><a href="http://universitycollege.du.edu/gis/?utm_medium=banner%20&#038;utm_source=geoawesomeness.com&#038;utm_campaign=ucol%20%20banner%20ads%20%20gis&#038;utm_content=geoawesomeness-FY21%20300x300"><img width="300" height="300" src="https://i0.wp.com/www.geoawesomeness.com/wp-content/uploads/2020/07/300_300_gis.jpg?fit=300%2C300&amp;ssl=1" class="image wp-image-33265  attachment-full size-full jetpack-lazy-image" alt="" loading="lazy" style="max-width: 100%; height: auto;" data-attachment-id="33265" data-permalink="https://www.geoawesomeness.com/300_300_gis/" data-orig-file="https://i0.wp.com/www.geoawesomeness.com/wp-content/uploads/2020/07/300_300_gis.jpg?fit=300%2C300&amp;ssl=1" data-orig-size="300,300" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="300_300_gis" data-image-description="" data-medium-file="https://i0.wp.com/www.geoawesomeness.com/wp-content/uploads/2020/07/300_300_gis.jpg?fit=300%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/www.geoawesomeness.com/wp-content/uploads/2020/07/300_300_gis.jpg?fit=300%2C300&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/www.geoawesomeness.com/wp-content/uploads/2020/07/300_300_gis.jpg?w=300&amp;ssl=1 300w, https://i0.wp.com/www.geoawesomeness.com/wp-content/uploads/2020/07/300_300_gis.jpg?resize=150%2C150&amp;ssl=1 150w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i0.wp.com/www.geoawesomeness.com/wp-content/uploads/2020/07/300_300_gis.jpg?fit=300%2C300&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></aside>
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-sidebar tdi_6_7af td_block_template_1 ">

<style>
/* custom css */
.tdi_6_7af.td-a-rec{
					text-align: center;
				}.tdi_6_7af .td-element-style{
					z-index: -1;
				}.tdi_6_7af.td-a-rec-img{
				    text-align: left;
				}.tdi_6_7af.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_6_7af.td-a-rec-img {
				        text-align: center;
				    }
                }
</style><script type="text/javascript">
var td_screen_width = window.innerWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6074512664048955" data-ad-slot="9647473255"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6074512664048955" data-ad-slot="9647473255"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:200px;height:200px" data-ad-client="ca-pub-6074512664048955" data-ad-slot="9647473255"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6074512664048955" data-ad-slot="9647473255"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 

                            </div>
                        </div>
                                    </div> <!-- /.td-pb-row -->
        </div> <!-- /.td-container -->
    </div> <!-- /.td-main-content-wrap -->

<!-- Instagram -->

	
	
            <div class="tdc-footer-wrap ">

                <!-- Footer -->
				
                <!-- Sub Footer -->
				    <div class="td-sub-footer-container td-container-wrap ">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span td-sub-footer-menu">
                                    </div>

                <div class="td-pb-span td-sub-footer-copy">
                    &copy; Geoawesomeness 2018                </div>
            </div>
        </div>
    </div>
            </div><!--close td-footer-wrap-->
			
</div><!--close td-outer-wrap-->


		<script type="text/javascript" alt='evo_map_styles'>
		/*<![CDATA[*/
		var gmapstyles = 'default';
		/* ]]> */
		</script>		
		
<!--BEGIN: TRACKING CODE MANAGER BY INTELLYWP.COM IN FOOTER//-->
<script type="text/javascript">
_linkedin_partner_id = "497577";
window._linkedin_data_partner_ids = window._linkedin_data_partner_ids || [];
window._linkedin_data_partner_ids.push(_linkedin_partner_id);
</script><script type="text/javascript">
(function(){var s = document.getElementsByTagName("script")[0];
var b = document.createElement("script");
b.type = "text/javascript";b.async = true;
b.src = "https://snap.licdn.com/li.lms-analytics/insight.min.js";
s.parentNode.insertBefore(b, s);})();
</script>
<noscript>
<img height="1" width="1" style="display:none;" alt="" src="https://dc.ads.linkedin.com/collect/?pid=497577&fmt=gif" />
</noscript>
<!--END: https://wordpress.org/plugins/tracking-code-manager IN FOOTER//-->	<div style="display:none">
	<div class="grofile-hash-map-e6d78d6d1ab72ff871bda9bf9813f104">
	</div>
	</div>


    <!--

        Theme: Newspaper by tagDiv.com 2020
        Version: 10.3.9.1 (rara)
        Deploy mode: deploy
        Speed booster: v4.4

        uid: 5fec7a8f7be83
    -->

    
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.0";
  fjs.parentNode.insertBefore(js, fjs);
}(document, "script", "facebook-jssdk"));</script><div id='evo_global_data' data-d='{"calendars":[]}'></div><div class='evo_lightboxes' style='display:block'>					<div class='evo_lightbox eventcard eventon_events_list' id='' >
						<div class="evo_content_in">													
							<div class="evo_content_inin">
								<div class="evo_lightbox_content">
									<a class='evolbclose '>X</a>
									<div class='evo_lightbox_body eventon_list_event evo_pop_body evcal_eventcard'> </div>
								</div>
							</div>							
						</div>
					</div>
					</div><script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.2.1/_inc/build/photon/photon.min.js' id='jetpack-photon-js'></script>
<script type='text/javascript' id='disqus_count-js-extra'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"geoawesomeness"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.geoawesomeness.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17' id='disqus_count-js'></script>
<script type='text/javascript' id='disqus_embed-js-extra'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"21437 https:\/\/www.geoawesomeness.com\/?p=21437","disqusShortname":"geoawesomeness","disqusTitle":"Insane, shocking, outrageous: Developers react to changes in Google Maps API","disqusUrl":"https:\/\/www.geoawesomeness.com\/developers-up-in-arms-over-google-maps-api-insane-price-hike\/","postId":"21437"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.geoawesomeness.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17' id='disqus_embed-js'></script>
<script type='text/javascript' id='lets-review-js-ext-js-extra'>
/* <![CDATA[ */
var letsReview = {"letsReviewLb":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.geoawesomeness.com/wp-content/plugins/lets-review/frontend/js/lets-review-ext.js?ver=1.2.0' id='lets-review-js-ext-js'></script>
<script type='text/javascript' id='lets-review-js-js-extra'>
/* <![CDATA[ */
var letsReview = {"letsReviewTitle":"Title","letsReviewAUrl":"https:\/\/www.geoawesomeness.com\/wp-admin\/admin-ajax.php","letsReviewNonce":"f0f2e2c3dd","letsReviewPostID":"21437"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.geoawesomeness.com/wp-content/plugins/lets-review/frontend/js/lets-review-scripts-source.js?ver=1.2.0' id='lets-review-js-js'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=202053' id='grofiles-cards-js'></script>
<script type='text/javascript' id='wpgroho-js-extra'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.2.1/modules/wpgroho.js' id='wpgroho-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.6/wp-includes/js/underscore.min.js' id='underscore-js'></script>
<script type='text/javascript' src='https://www.geoawesomeness.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=a50385a2d79d6600973a7e697f735a0b' id='tdb_js_posts_autoload-js'></script>
<script type='text/javascript' src='https://www.geoawesomeness.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=10.3.9.1' id='td-site-min-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.6/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' src='//www.geoawesomeness.com/wp-content/plugins/eventON/assets/js/eventon_functions.js?ver=3.0.6' id='evcal_functions-js'></script>
<script type='text/javascript' src='//www.geoawesomeness.com/wp-content/plugins/eventON/assets/js/lib/jquery.easing.1.3.js?ver=1.0' id='evcal_easing-js'></script>
<script type='text/javascript' src='https://www.geoawesomeness.com/wp-content/plugins/eventON/assets/js/lib/handlebars.js?ver=3.0.6' id='evo_handlebars-js'></script>
<script type='text/javascript' src='//www.geoawesomeness.com/wp-content/plugins/eventON/assets/js/lib/jquery.mobile.min.js?ver=3.0.6' id='evo_mobile-js'></script>
<script type='text/javascript' src='https://www.geoawesomeness.com/wp-content/plugins/eventON/assets/js/lib/moment.min.js?ver=3.0.6' id='evo_moment-js'></script>
<script type='text/javascript' src='//www.geoawesomeness.com/wp-content/plugins/eventON/assets/js/lib/jquery.mousewheel.min.js?ver=3.0.6' id='evo_mouse-js'></script>
<script type='text/javascript' id='evcal_ajax_handle-js-extra'>
/* <![CDATA[ */
var the_ajax_script = {"ajaxurl":"https:\/\/www.geoawesomeness.com\/wp-admin\/admin-ajax.php","rurl":"https:\/\/www.geoawesomeness.com\/wp-json\/","postnonce":"eda4f6b8bc","ajax_method":"ajax"};
/* ]]> */
</script>
<script type='text/javascript' src='//www.geoawesomeness.com/wp-content/plugins/eventON/assets/js/eventon_script.js?ver=3.0.6' id='evcal_ajax_handle-js'></script>
<script type='text/javascript' src='https://www.geoawesomeness.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/lazy-images.min.js?ver=1.0.0' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' src='https://apis.google.com/js/plusone.js?ver=5.6' id='plusone-js'></script>
<script type='text/javascript' src='https://platform.twitter.com/widgets.js?ver=5.6' id='twittersdk-js'></script>
<script type='text/javascript' src='https://platform.linkedin.com/in.js?ver=5.6' id='linkedin-js'></script>
<script type='text/javascript' src='https://www.geoawesomeness.com/wp-content/plugins/layered-popups/js/script.min.js?ver=5.91' id='ulp-js'></script>
<script type='text/javascript' src='https://www.geoawesomeness.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=a50385a2d79d6600973a7e697f735a0b' id='tdb_js_files_for_front-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.6/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script type='text/javascript' src='https://maps.googleapis.com/maps/api/js?ver=1.0' id='evcal_gmaps-js'></script>
<script type='text/javascript' src='//www.geoawesomeness.com/wp-content/plugins/eventON/assets/js/maps/eventon_gen_maps.js?ver=3.0.6' id='eventon_gmaps-js'></script>
<script type='text/javascript' src='//www.geoawesomeness.com/wp-content/plugins/eventON/assets/js/maps/eventon_init_gmap.js?ver=1.0' id='eventon_init_gmaps-js'></script>
<script type='text/javascript' id='jetpack-carousel-js-extra'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/www.geoawesomeness.com\/wp-admin\/admin-ajax.php","nonce":"bd747b1cee","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"0","login_url":"https:\/\/www.geoawesomeness.com\/wp-login.php?redirect_to=https%3A%2F%2Fwww.geoawesomeness.com%2Fdevelopers-up-in-arms-over-google-maps-api-insane-price-hike%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.2.1/_inc/build/carousel/jetpack-carousel.min.js' id='jetpack-carousel-js'></script>

<!-- JS generated by theme -->

<script>
    
</script>


<!-- Header style compiled by theme -->

<style>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</style>

<script type='text/javascript' src='https://stats.wp.com/e-202053.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.2.1',blog:'36753651',post:'21437',tz:'1',srv:'www.geoawesomeness.com'} ]);
	_stq.push([ 'clickTrackerInit', '36753651', '21437' ]);
</script>

		<script>
			var ulp_ajax_url = "https://www.geoawesomeness.com/wp-admin/admin-ajax.php";
			var ulp_css3_enable = "on";
			var ulp_ga_tracking = "off";
			var ulp_km_tracking = "off";
			var ulp_onexit_limits = "off";
			var ulp_no_preload = "off";
			var ulp_campaigns = {"ab-2x5kfZ4WzTfkoZLx":[""],"none":[""]};
			var ulp_overlays = {"none":["", "", "", "", ""]};
			if (typeof ulp_inline_open == "function" && typeof ulp_init == "function") { 
				ulp_prepare_ids(); ulp_inline_open(false); ulp_init(); jQuery(document).ready(function() {ulp_ready();});
			} else {
				jQuery(document).ready(function(){ulp_prepare_ids(); ulp_inline_open(false); ulp_init(); ulp_ready();});
			}
		</script>
</body>
</html>